Mage
Search…
⌃K

Setup and install

Setup

You can install Mage using Docker or pip:

Using Docker

  1. 1.
    Create new project and launch tool
    docker run -it -p 6789:6789 -v $(pwd):/home/src mageai/mageai \
    mage start [project_name]
  2. 2.
    Open http://localhost:6789 in your browser and build a pipeline.
  3. 3.
    Run pipeline after building it in the tool
    docker run -it -p 6789:6789 -v $(pwd):/home/src mageai/mageai \
    mage run [project_name] [pipeline]

Initialize new project

If you want to create a different project with a different name, run the following:
docker run -it -p 6789:6789 -v $(pwd):/home/src mageai/mageai \
mage init [project_name]

Using pip or conda

  1. 1.
    Install Mage
    pip install mage-ai
    or
    conda install -c conda-forge mage-ai
    If you run into errors, see the errors section below.
  2. 2.
    Create new project and launch tool
    mage start [project_name]
  3. 3.
    Open http://localhost:6789 in your browser and build a pipeline.
  4. 4.
    Run pipeline after building it in the tool
    mage run [project_name] [pipeline]

Initialize new project

If you want to create a different project with a different name, run the following:
mage init [project_name]

Download new version of Mage

Using Docker

docker pull mageai/mageai:latest

Using pip

pip install -U mage-ai

Install

Installing extra packages

Mage also has the following extras:
  • spark: to use Spark in your Mage pipeline
  • bigquery: to connect to BigQuery for data import or export
  • hdf5: to process HDF5 file format
  • postgres: to connect to PostgreSQL for data import or export
  • redshift: to connect to Redshift for data import or export
  • s3: to connect to S3 for data import or export
  • snowflake: to connect to Snowflake for data import or export
  • all: to install all of the above to use all functionalities
Example:
pip install "mage-ai[spark]"

Errors

You may need to install development libraries for MIT Kerberos to use some Mage features.
On Ubuntu, this can be installed as:
apt install libkrb5-dev

Development environment

To setup a development environment for editing source code, please check out this document.

Building your own Docker image

docker build -t mage/dangerous .